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7. The Recall List box displays all the output | 2.
that the users have written or typed in the

command input box.

8. The purple color-coded Looks blocks are

used to control a Sprite's appearance.

C. Write the shortcut keys for the following.

The shortcut key for:

1. Undois Ctrl + Z.

3. Copy is Ctrl + C.

5. Underline is Ctrl + U.

6. Selectall 1s Ctrl + A.

7. Right alignment is Ctrl + R.

D. Write True or False for the following statements.

1. Talse 2. True 3. True
4. True 5. True
Cyber Olympiad

Tick (v) the correct option for each question.
1. (d) 2. (a) 3. (c)
4. (b) 5. (c) - (d)
7. (b) 8. (d) 9 (c)
10. (a) 11.(b) 12.(c)
13.(c) 14.(d) 15.(a)
16. (a) 17.(b) 18.(a)
19. (c) 20.(d)

CAEEENN Generations of Computer
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Rapid Fire

1. Reynold B. Johnson is regarded as the father of

the disk drive.

Keys "

2. Boldis Ctrl + B.
4. Pasteis Ctrl +V.

The main working component of second-
generation computers was transistor.

A microcomputer is also known as the personal
computer.

Supercomputers are used for weather forecasting.

Let's Review

. Tick (V) the correct option.

1. (b) 2. (a) 3. (¢)
4. (d) 5. (d)
. Write True or False for the following statements.
1. True 2. False 3. True
4. False 5. True

. Give two examples of each of the following.

Two examples of the:

1. first generation computers are UNIVAC-I
and ENIAC.

2. second generation computers are UNIVAC
1108 and IBM 7077.

3. third generation computers are Alter and
IBM 370.

4. fourth generation computers are desktop and
laptop.

D. Answer the following questions.

1. Computers that used transistors instead
of vacuum tubes are called the second
generation computers. The use of transistors
made computers smaller, faster, more reliable
and cheaper.

2. The mainframe computers are the powerful
multiuser computers capable of supporting
many hundreds or thousands of users
simultaneously. They have faster speed,
bigger memory and mass storage capacity.
They are used by big companies and
enterprises.

3. The main features of the fourth-generation
computers are:

e They are microprocessor-based
computers.
e They use microprocessor chips called
VLSI (Very Large Scale Integration).
e They are compact, powerful, fast and
much cheaper.
4. A supercomputer is the fastest and most
powerful computer. It supports several
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processors for solving complex scientific
problems. It can perform typical calculations
within seconds.

5. The three characteristics of computers are
their speed, accuracy, and versatility.

P ctivity Time

The complete crossword puzzle is given below.
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More on Windows 10
Activity Time
Click the Personalize option.

Select the colour you want to change and click
onit.

Select the solid color option in the Background.

Right click on an empty area of the desktop.

Click the Background option.
Rapid Fire

1. The Screen Saver appears on the screen if the
computer is left idle for some time.

o

The Wait box in Screen Saver Settings window is
a box used to set the time.

@

A list of different properties of mouse appears on
clicking the Change mouse pointers link.

4. Desktop gadgets could be positioned around the
desktop, but mostly they are arranged at bottom-
right positions of the desktop

Let's Review

A. Tick (V) the correct option.
1. (a) 2. (¢) 3.
4. (b) 5. (¢)

Drag & Drog

B. Write True or False for following statements.
1. True 2. TFalse 3. True
4. True 5. True

C Answer the following questions.
1. The latest version of the Windows operating
system is Windows 11.
2. The desktop background is the pattern that
displays on the desktop.

3. The steps to change the desktop background
are:

¢ Right-click on the empty area of the
desktop. A short-cut menu appears on the
screen.

*  Click the Personalize option.
*  (Click the Background option
 Select the background you want to change
and click it.
The Desktop Background of the computer screen

changes according to the given selection.

4. Screen saver is a moving graphic or image
which appears on the screen if the computer
is left idle for some time. We can change the
screen saver.

5. Adding icons to desktop means to add more
icons to the desktop other than the by default
icons.

Brain Teager
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More on MS Word 2016
Rapid Fire

1. Themost popular word processing software used
across the globe is Microsoft Word.

2. The Title Bar displays the title of the document.
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3. The blank space around the edges of page called
margin

4. MS Word has two types of orientations.

5. The Line Spacing button is found in Paragraph
group.

Brain Teager
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Let's Review
A. Tick (v) the correct option.

1. (b) 2. (d)
3. (c¢) 4. (¢)
B. Match the following.
1. (¢ 2. (d)
3. (a) 4. (b)
C. Write True or False for the following statements.
1. False 2. False 3. True
4. True 5. False 6. False

D. Answer the following questions.

1. Margins are the space between the edge of the
page and the document text on all the four
sides. We can access page margin settings
options from the Page Setup group in the
Page Layout Tab.

I ctivity Time

2. The two types of page orientation are portrait
orientation and landscape orientation.
Portrait page orientation is where the vertical
size 1s greater than the horizontal size.
Landscape page orientation is where the
horizontal size is greater than the vertical size.

3. WordArt is a text decorative styling utility
in MS Word that we can add to a document.
We can make changes to WordArt, such as
the font size and the text colour, by using the
drawing tools options available automatically
after you insert or select the WordArt in a
document.

4. The steps to divide the text into columns are:
»  Select the text.
» Click the Layout tab in Page Setup group.
» Click the Columns tab in Page Setup
group. A list appears on the screen.

» Click the option you want to apply, say
two columns. The selected text gets
divided into two columns.

5. The steps to insert a picture from your file
are:

* Click on the Insert tab.

» First click the Picture option and then
This Device option from the Illustrations
group. The Insert Picture dialog box
appears.

» Select the picture.

* Click the Insert button. The selected
picture will be inserted in your document.

Icon | Button name Group Tab Use
[l | Margin Page Setup  |Page Layout |t is used to change document margin.
g8 | Clip Art [lustrations |Insert These graphic pictures can be added in text.
Insert picture | Illustrations |Insert It is used to insert pictures from a file or folder.
[ |Orientation |PageSetup |Page Layout |Itisused tochange layout of the printing page.
A4 | WordArt Text Insert It is used to decorate text such as font style.

Keys "
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LOGO Procedures

Rapid Fire

1. Title always starts with the word To.

2. A procedure cannot have arithmetic operators.

3. File-Erase option in File menu erases procedures.

4. You can load the saved procedure by using
LOGO command.

K ctivity Time

The students will do it themselves.

Let's Review

A. Identify the part of procedure for the following
commands.

1. Body 2. Body 3. End

B. Tick (v) the correct names for procedure and
cross (X) out the wrong ones.

1. 12March X 2. Akash v
3. 5thRow X 4. FD X
5. RT90 X 6. TO Square v/
C. Answer the following questions.
1. MSW LOGO is a graphic oriented

programming language which interprets on
the basis of computer language LOGO.

2. A LOGO procedure is a set of LOGO
commands given one after the other to
perform a particular task and referred by a
specific name.

3. Some of the rules for writing a procedure are
given below:

* A procedure can have letters, numbers
and symbols.

e The first character of the procedure's
name should always be a letter.

e A procedure’s name cannot include
names of any LOGO commands.

e A procedure cannot have blank spaces
and arithmetic operators.

4. Let us draw an equilateral triangle. An
equilateral triangle has all sides equal and
each angle 60°. The procedure for making a
triangle 1s:

e Type To TRIANGLE in the input box
and press the Enter key.

Drag & Drog

e Type REPEAT 3FD 50RT 60 command.

e Type END in the input box and click the
OK button.

An equilateral triangle will appear on the screen.

5. Two ways of writing a procedure:

(a) Using the a REPEAT command: Let
us draw a square. The steps to write a
procedure for drawing a square are:

e Type TOSQUARE and press the
Enter key. The TO mode appears on
the screen.

» Type REPEAT4 [FD100 RT90]

¢ Type END in the input box.

» Click the OK button and press the
Enter key. The LOGO screen displays

a square.

(b) Procedure with Parameters: In this
method, we can use one procedure to
draw squares of different sizes. Here is an
example. Type the following:

« TOSQUARE :SIZE
« REPEAT 4 [FD :SIZE RT 90]
« END

Model Test Paper — |

A. Tick (V) the correct option.
1. (a) 2. (c) 3. (d) 4.
5. (b) 6. (a) 7. (a) 8.

B. Answer the following questions.

(b)
(b)

1. A mainframe computer is one of the fastest
and most powerful computers.

2. Screen saver is a moving graphic image that
appears on the screen if the computer is idle
for some time.

3. In banks, computers are used to maintain
account records of customers. Computers
assist bankers to stay in touch with banking
policies.

4. Gadgets are electronic, electrical or
mechanical devices that we use frequently in
our routine life.

5. Margins are the space between the edge of the
page and the document text on all the four
sides. We can access page margin settings
options from the Page Setup group in the
Page Layout Tab.

@ -



6. Page orientation in a document is the layout
of a page for printing.
7. WordArt is the decorative text that we can

add to a document.

8. The three characteristics of a computer are
their speed, accuracy, and versatility.

9. Steps to the shading effect to a shape in Word:
»  Select the shape.

* Click the down arrow of Shape Effect
option. A gallery of different effect styles
appears.

 Select the shape effect of your choice and
click it. The shape effect applies on the

shape.
C. Write True or False for the following statements.
1. False 2. True 3. False 4. True
5. True 6. True 7. True 8. True
D. Match the following.
1. (b) 2. (¢ 3. (e)
4. (D) 5. (a) 6. (d)

More on PowerPoint 2016

Brain Teaser

1. Click the Start button.

2. Search and click the Microsoft Office folder.
3. Click the PowerPoint 2016 option.

4. Click the New option.

P ctivity Time

The solved crossword puzzle is given below.
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Rapid Fire
1. A collection of slides arranged in a systematic
order is called a presentation.

2. The biggest area in the middle of the screen is
called a slide.

3. The dotted boxes are called placeholders.

Let's Review
A. Tick (V) the correct option.

L. (c) 2. (a) 3. ()
4. (c) 5. (b)
B. Write True or False for the following statements.
1. True 2. True 3. False
4. True 5. False 6. False
7. True
C. Match the following.
1. (¢) 2. (e) 3. (d)
4. (a) 5. (b)

D. Answer the following questions.

1. In PowerPoint, a presentation is a group
of slides arranged in a systematic order
displaying information along with graphics,
movies, sound, etc.

2. MS PowerPoint is a presentation software
which is used to make presentations for
personal and professional purposes.

3. In PowerPoint, a slide layout is an
arrangement of placeholders which are
designed to help us position the slide content.

4. The steps to insert Word Art:

*  Click the Insert tab.
» Select the text.

*  Click the WordArt button from the Text
group. The WordArt gallery appears.

» Select the WordArt of your choice and
click it. The selected WordArt will be

applied.
5. The steps to change the font style:
e Select the text.

* Click the drop-down arrow next to the
Font box on the Home tab. The font style
drop-down menu appears.

» Select the text of your choice.

The selected text style will be changed.
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More on Internet
I ctivity Time
The labelled picture is given below.
Title Bar Forward Button Tabs

Address Bar

Refresh Button

— .,
Back Buttorj :
Favourite
Button Command
o Bar
Recent 1 my msn . ull msn index
Pages 8 20 Most Important NFL
L Players (for Now)
. o
: |
Confusion swirls over _
fate of American
seized In Pakistan .
P ctivity Time C. Answer the following questions.

The words related to computer networks and
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Rapid Fire

1. The popular websites which provide the facility
to send and receive mails are: www.yahoo.com,
www.gmail.com and Outlook.com

2. E-mail stands for Electronic mail.
3. WWW button is used for URL address of a

particular site.

Let's Review
A. Tick (V) the correct option.

1. (c) 2. (a) 3. (b)
4. (b)

B. Write True or False for the following statements.
1. False 2. False 3. True
4. True 5. False

Drag & Drog

1. A computer network is a set of computers
connected together through a communication
media to exchange information and data.

2. MAN, stands for Metropolitan Area
Network, is a computer network usually
spanning a few local area networks using high
speed backbone technologies.

3. To use the Internet, we need these four
things: Telephone line, modem, computer,
and an ISP (Internet Service Provider).

4. A search engineis a software system (website)
designed to carry out web searches using the
Internet.

5. A URL, stands for Uniform Resource
Locator, is the unique address given to a
website on WWW,

6. The main difference between a web page
and a website is that a web page is a single
document containing text, images,videos,
animation, etc., whereas a website is a
collection of related web pages.

Brain Teager
1. SEARCH ENGINE
3. ADDRESS BAR
5. WEBSITE

I ctivity Time

The students will do it themselves.

2. CHAT
4. URL
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Algorithm and Flowcharts

Rapid Fire

1. We use the connector box (circular in shape)
to connect two statements situated at different
places in a program.

2. In a flowchart, the flow lines are arrows which
connect two boxes. They determine the flow of
the instructions used in a program.

The decision box is used to display final result.

The processing box is used to show the processing
steps in a flowchart.

Let's Review

A. Tick (V) the correct option.
1. (¢ 2. (¢ 3. (b)
4. (a) 5. (b)
B. Write True or False for the following statements.
1. False 2. False 3. True
4. True 5. True
C. Match the following.
1. (d) 2. (a) 3. (b) 4. (¢
D. Answer the following questions.

1. An algorithm is a sequence of steps used for
solving a problem.

2. A flowchart is a pictorial representation of
the separate steps of a process in sequential
order, used for solving a specific problem.

3. The input/output box is used to show the
input and output related steps in a flowchart.

Introduction to MS Excel 2016
I ctivity Time
The labelled picture is given below.

Quick Access Toolbar ~ Formula Bar

4. An algorithm is a procedure or set of
rules that defines how a program is to be
executed, whereas a flowchart is a pictorial
representation of the steps taken in solving a
problem.

I ctivity Time

The flowcharts for the given algorithms are given.
Algorithm 1 Algorithm 2

Cstart
¥

{
' !

I Let Average=(A+B+C)/3 ‘

:
v

Print Average
v | Let Perc = (MO*100)/MM |

¢

Else If Perc > =50
display "II Div"

Else If Perc > = 60
display "I Div"

Ise If Perc > = 40
display "ITI Div"

Else display
n Fail"

Title Bar

Ribbon

Clll e bbb
3
4
:
Worksheet—%
i Status
- ==—— .
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Brain Teager

Terms used in Excel are circled in the grid.
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»  Click the Blank workbook from the given
templates.

The new worksheet gets opened on the screen.

6. Steps to save the workbook:

»  Click the File tab.

»  Click the Save option. The Save As dialog
box appears.

»  Click This PC option.

* Type the name of the file in the File name
box.

*  Click the Save button.

The workbook gets saved in the given location.

Rapid Fire More on Scratch
1. Thereare 10,48,576 rows and 16,384 columns in | Rapid Fire

Excel 2016 worksheet 1

is Book1, Book2, Book3, etc. But we can easily
rename them. 3

3. We can enter only three types of data in MS
Excel worksheet.: numbers, text, and formulae.

Let's Review

A. Tick (V) the correct option. A

1. d) 2. (c) 3. (b)
4. (d)

B. Write True or False for the following statements. | B,

1. True 2. True 3. False
4. False 5. True

C. Answer the following questions.

1. A spreadsheet software is a special type of
software that results and analyses the entered
data arranged in rows and columns.

2. In Excel, a worksheet is a collection of cells
where we keep and manipulate data.

3. In Excel, a sheet, also called a worksheet, is a
single page or a document with the collection
of cells to help us organize the data.

4. In Excel, the formula box displays the cell C
contents along with the formulae written for
the particular cell. b

5. Steps to create a new worksheet:
*  Click the File tab.

e Click the New option. A list of templates
appears.

Drag & Drog '@'

. There are 77 stack blocks in Scratch.
2. The default name of workbook in Excel 2016 | 5.

Cap blocks are shaped with a notch at the top and
a flat bottom.

. Pen blocks are used to allow a Sprite to draw

shapes, plot coloured pixels, and so forth on
the screen.

Let's Review

. Tick (V) the correct option.

1. (a) 2. (o) 3. (d)

4, (a) 5. (¢)

Fill in the blanks with the correct words given
below.

1. Alooping block repeats a set of blocks a given
number of times until the condition is met.

2. Looks blocks affect how your sprites appear
on the Stage.

3. A Stake block is a rectangular block.

4. In Scratch, the Sprite moves on the Stage
when we run the program.

5. An event-driven script is one that executes
when a specified event occurs.

Write True or False for the following statements.
1. False 2. False 3. False
4. False 5. True

. Answer the following questions.

1. Conditional blocks are control blocks that use
a condition to determine whether a Boolean
condition supplied by the programmer is true
or false.
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2. In Scratch, direction is measured in degrees
(°) and it ranges from —180° to 180° (both
pointing down). The default value for the
direction is 90°, pointing right. Whether
the sprite is actually visually rotated or not is
determined by the sprite's rotation style.

3. In Scratch, scripts are programs that control
Sprites. Scripts are programmed to make the
Sprites do things.

4. Motion blocks are used for the movement
and rotation a Sprite.

5. Control Blocks programmed  for
functioning the Sprites as long as certain
conditions are met. These blocks do not do
anything until users use them as part of a
script, but click the Create Clone of Myself
block. Similar to what happened when
clicked the Stamp block under the Pen Block
category, the two copies of a Sprite, say Cat
Sprite, are on top of one another on the Stage.

are

Note: To know the functioning of different types of
Control blocks, see page 91 of the book.

6. Reporter blocks are coded blocks that have
either rounded or angled sides. They are
designed to provide information for other
code blocks to process.

P ctivity Time
The students will do it themselves.

Artificial Intelligence (Machine
Learning)

Let's Review

A. Tick (V) the correct option.
1. (d) 2. (a) 3.
4. (c) 5. (b)

B. Fill in the blanks with the words given below.

(a)

1. Artificial intelligence develops machines that
can accomplish tasks that require human
intelligence.

2. Unsupervised learning uses unlabelled data.
3. Cortana is a virtual personal assistant.

4. Sentiment analysis application is used to
analyse a review based website.

5. Feed Forward Neural Network helps banks
know fraud transactions.

C. Write True or False for the following statements.
1. True 2. True 3. True
4. TFalse 5. True

D. Answer the following questions.

1. Machine learning is an application of
artificial intelligence that provides the system
the ability to learn and improve automatically
from experience without being programmed

2. Factors on which our likes or dislikes for
listening to a song depend are: intensity,
tempo, genre and gender of voice.

3. There are many ways to classify machine

learning problems. Some of them are
supervised learning, unsupervised learning,
semi-supervised learning and reinforcement

learning.

4. Supervised learning algorithms apply past
experiences labelled to be trained, whereas
unsupervised learning algorithms use neither
classified nor labelled data to be trained.

5. Machine learning is very useful in the
banking sector. It helps prevent fraud and
protects accounts from hackers.

I ctivity Time

Cortana

Google assistant

Alexa

-

>
g
Siri

Model Test Paper — Il
A. Tick (V) the correct option.

1. (d) 2. (o) 3. (a)
4. (b) 5. (¢) 6. (b)
7. (¢ 8. (b) 9. (¢
10. (a)
B. Write True or False for the following statements.
1. False 2. False 3. False
4. True 5. False
C. Rearrange the jumbled letters to form the correct
words.
Drag & Drop



1. TERMINAL BOX
3. FLOW LINES
5. SCRATCH

D. Answer the following questions.

2. WORDART
4. CHAT

1. A flowchart is a pictorial representation of
the separate steps of a process in sequential
order, used for solving a specific problem.

2. Search engine is a website which we use to
search information on the Internet.

3. An algorithm is a procedure or set of
rules that defines how a program is to be
executed, whereas a flowchart is a pictorial
representation of the steps taken in solving a
problem.

4. PowerPint is a presentation software that
helps the users to make presentations.

5. In Excel, a worksheet is a collection of cells
where we keep and manipulate data.

6. The main difference between a web page
and a website is that a web page is a single
document containing text, images,videos,
animation, etc., whereas a website is a
collection of related web pages.

7. In Excel, the Formula box is a box which
shows the cell contents along with the
formulae written for that particular cell.

8. Today, the Internet has become a part of our
daily life. It is because the use of the Internet
makes our life easy, fast and simple.

9. Control blocks are used to control Scripts
under certain conditions, which can be done
by inserting conditional statements, loops,
repeats, and causes.

10. Machine learning is an application of
artificial intelligence that provides the system

the ability to learn and improve automatically

from experience without being programmed.
Cyber Olympiad
Tick (v) the correct option for each question.
1. (d) 2. (a) 3. (¢ 4. (b)
5. (¢) 6. (d) 7. (b) 8. (d)
9. (c) 10. (c) 11.(a) 12.(b)
13.(c) 14. (c) 15.(d) 16.(a)
17.(a) 18. (B) 19.(c) 20.(d)
Drag & Drog

i Class |l 64
Computer System
I ctivity Time
(a) mouse (b) joystick
(¢) drum scanner (d) microphone
Brain Teager
The full form of:
(a) ROM: Read Only Memory
(b) RAM: Random Access Memory
(c) CD: Compact Disc
(d) DVD: Digital Video/ Versatile Disc
(e) USB: Universal Serial Bus
Rapid Fire

1. Pen drive is plug-and-play device that simply
plugs into a USB port of a computer.

2. Web camera allows you to capture images and
input them into the computer.

CPU is the brain of a computer system.

Touch screen enables a user to choose available
options by simply touching the icon or menu
displayed on a computer's screen.

Brain Teaser

1. /D|V|D 2./C|P|U
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Let's Review
A. Tick (V) the correct option.

1. (¢) 2. (a) 3. (¢)
4. (a) 5. (b)
B. Write T for true and F for false statements.
1. F 2. T 3. F
4. T 5. F 6. F
7. T

C. Fill in the blanks.
1. A mouse is a pointing device consisting of a
plastic stick mounted on a base.

2. Microphone contains a device called amplifier
inside it.
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