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1. TERMINAL BOX
3. FLOW LINES
5. SCRATCH

D. Answer the following questions.

2. WORDART
4. CHAT

1. A flowchart is a pictorial representation of
the separate steps of a process in sequential
order, used for solving a specific problem.

2. Search engine is a website which we use to
search information on the Internet.

3. An algorithm is a procedure or set of
rules that defines how a program is to be
executed, whereas a flowchart is a pictorial
representation of the steps taken in solving a
problem.

4. PowerPint is a presentation software that
helps the users to make presentations.

5. In Excel, a worksheet is a collection of cells
where we keep and manipulate data.

6. The main difference between a web page
and a website is that a web page is a single
document containing text, images,videos,
animation, etc., whereas a website is a
collection of related web pages.

7. In Excel, the Formula box is a box which
shows the cell contents along with the
formulae written for that particular cell.

8. Today, the Internet has become a part of our
daily life. It is because the use of the Internet
makes our life easy, fast and simple.

9. Control blocks are used to control Scripts
under certain conditions, which can be done
by inserting conditional statements, loops,
repeats, and causes.

10. Machine learning is an application of
artificial intelligence that provides the system

the ability to learn and improve automatically

from experience without being programmed.
Cyber Olympiad
Tick (v) the correct option for each question.
1. (d) 2. (a) 3. (¢ 4. (b)
5. (¢) 6. (d) 7. (b) 8. (d)
9. (c) 10. (c) 11.(a) 12.(b)
13.(c) 14. (c) 15.(d) 16.(a)
17.(a) 18. (B) 19.(c) 20.(d)
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Computer System
I ctivity Time
(a) mouse (b) joystick
(¢) drum scanner (d) microphone
Brain Teager
The full form of:
(a) ROM: Read Only Memory
(b) RAM: Random Access Memory
(c) CD: Compact Disc
(d) DVD: Digital Video/ Versatile Disc
(e) USB: Universal Serial Bus
Rapid Fire

1. Pen drive is plug-and-play device that simply
plugs into a USB port of a computer.

2. Web camera allows you to capture images and
input them into the computer.

CPU is the brain of a computer system.

Touch screen enables a user to choose available
options by simply touching the icon or menu
displayed on a computer's screen.

Brain Teaser

1. /D|V|D 2./C|P|U

s lcloN|T|R[ofL][U|N|I]T]|
+[pfofr|[mla[T|R[I[X]
s. [PlE[NJ[DIR|T]V]E]

Let's Review
A. Tick (V) the correct option.

1. (¢) 2. (a) 3. (¢)
4. (a) 5. (b)
B. Write T for true and F for false statements.
1. F 2. T 3. F
4. T 5. F 6. F
7. T

C. Fill in the blanks.
1. A mouse is a pointing device consisting of a
plastic stick mounted on a base.

2. Microphone contains a device called amplifier
inside it.

-



5.

. The main circuit board of a computer which

lies inside the CPU box 1s known as the
motherboard.

Secondary storage is also known as external
memory.

DVD stands for Digital Video/ Versatile Disc.

D. Answer the following questions.

1.

Devices that accept instructions and data
from the users and convert them into a
binary form that the computer understands
are called input devices. The keyboard, the
mouse, scanner, and microphone are some
input devices.

The keys of a keyboard are classified into six
main categories as given below:

(a) Alphanumeric keys

(b) Control keys

(¢) Function keys

(d) Numeric keys

(e) Spacebar and Arrow keys
(f) Special keys

CPU, the brain of a computer, functions
through the following two parts:

(a) Arithmetic Logic Unit: It is an integrated
circuit within a CPU that performs
arithmetic  and  logic  operations.
Arithmetic operations include addition,
subtraction, and shifting operations,
while logic unit includes the logical
operations.

(b) Control Unit: It controls the flow of binary
data or information in the computer.

The main difference between RAM and
ROM is that RAM is a type of volatile
memory in which data is kept temporary,
whereas ROM is a type of non-volatile
memory in which data is not lost even if the
computer is switched off.

Output devices are computer hardware that
receive data from the computer and then
translate that data into usable form for the
use of the user.

P ctivity Time

Ten input, output and storage devices are encircled

in the grid.
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CEEEPE More on Windows

Brain Teager

1. (iv) 2. (viii) 3. (i)
4. (vi) 5. (i) 6. (vii)
7. (V) 8. (iil)

I ctivity Time
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I ctivity Time

Select ‘Cut’ option

Click on ‘Paste’ option

Click on ‘Organize’ button

Click the file/folder that you want to move

Select and open the folder where you want the
file or folder to be moved

] FI=I=]=]e]

Click on ‘Organize’ button

Rapid Fire
1. The Windows Explorer window 1s used to
manage your libraries, folders and files.

DN

Medium Icons View displays your files and
folders as medium icons.

3. Address Bar shows the location of the current
window.

4. Favourite area helps you to access folder or file as
easily as possible.

Drag & Drop



I ctivity Time
1.The students will do it themselves.
2.The labelled picture is given below.

Forward Button

Back
Button

Address Bar

Refresh Button  Search Box

']
Libraries
enu ore
Control Bar < J\) = i Options
<F < = <>
Documents Music Pictures Videos
Get Help
Navigation
Pane |
Details T
Pane (i

Let's Review
A. Tick (V) the correct option.
1. (a) 2. (d) 3. (d)
4. (d) 5. (b)
B. Fill in the blanks.
1. Windows Explorer window manages the

resources of the computer system and does
many other things.

2. Search box is used to find folders, files and
libraries in Windows Explorer.

3. Back button helps to take you to previously
viewed folder.

4. The Change your view option in Menu
Control bar contains several options.

5. At the top of the Navigation pane, you will
find the Quick access.

C Answer the following questions.
1. The main features of the Windows 10 are:

» File Explorer, which is the replacement of
Windows Explorer of Windows 7.

e Managing Folder: In Windows 10, you
can create a new folder by right-clicking
on the empty portion in the right pane of

Drag & Drop

File Explorer Window and selecting New
— Folder options. Now, type the folder
name.

e The Recycle Bin: It is somehow different
than that of Windows 7. It has a menu bar
with options File, Home, Share, View and
Manage.

2. Windows 10 is a Microsoft operating system
for PCs, laptops, tablets, and many more
devices. It acts as an interface between the
computer hardware and the user. It was
officially released on 29 July 2015.

3. Windows Explorer, also called File
Explorer in Windows 10, 1is a graphical
file management utility for the Windows
operating system. It manges libraries, folders
and files in the computer.

4. Steps to create a new folder in Windows
Explorer:

»  Click the New Folder option in the Menu
Control Bar.

e Write the name for the new folder.
* Press the Enter key.

The folder with new name is created.

.7 Keys



5. In computer, Recycle Bin is a place where
deleted files or folders or images are
temporarily stored. They remain in Windows
unless they are permanently deleted. If we
delete anything accidentally, we can restore it
from the Recycle Bin.

6. Steps to delete a folder from Windows

Explorer:

»  Click the folder to be deleted.

*  Click the Organize button. A drop-menu
appears on the screen.

e Select the Delete option. The Delete
Folder message box appears confirming
to delete the folder.

* Click Yes to delete the folder or No to

cancel the operation.

Brain Teager
v Blajelk| B juiT|T |0 N
2 [Emlp[T]v][T|H]E |

(RlE[c]vc[L]E][B]1[N]
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P ctivity Time

The use of the highlighted option in each menu is
given below the picture.

Orgenize | 5 Open
& cu View
L Copy Sort by

Include

o) Refresh

Customize this folder.

Folder and search options

X Dete
Rename
Remon
Propertes

Sh

®

Shared Folder Synchronization

New

e Propeties

It is used to resize the
icons to medium.

It is used to copy the
selected text or image.

Folder

sh
(5 Shared Folder Synchronization

New

Properties

It 1s used to make a new shortcut.

More on MS Word 2016

Brain Teager

1. (d) 2. (O 3. (a)
4. (e) 5. (b) 6. (c)
Rapid Fire

1. The Title bar displays the name of the currently
working document.

2. Ribbon is located near the top of the screen,
below the Quick Access Toolbar.

3. Status bar displays the number of words in the
document.

4. Close button is used to close MS Word window.

Let's Review
A. Tick (V) the correct option.

1. (d) 2. (b) 3. (a)
4. (d)
B. Write T for true and F for false statements.
1. T 2. T 3. T
4. T 5. F

C. Answer the following questions.

1. A table helps to organise text and other
contents on a page. It is very useful in
representing data effectively. It consists of
rows and columns.

2. The steps to add a table in a document:

* Point the cursor where the table is to be

added.
¢ Click the Insert tab.
¢ Click the Table button in the Table group.

e Drag the mouse over the table cells to
select the number of columns and rows in

the table.
* Left click the mouse on the bottom-right
corner of the cell.
The table appears in the document.
3. The steps to add a row in a table:

¢ Select the row next to which the row is to
be inserted.

¢ Click the Layout tab in Table tools.
e Click the Insert Above or Insert Below
button in the Rows & Columns group.

The empty row will be inserted at the
required place in the table.

Drag & Drop



4. The steps to change column width in a table:

e Select the column of which width is to be
changed.

* Click the Layout tab.
»  Type the value to set the width in the Cell
Size group.
The size of the given cell gets changed.
5. The steps to convert an existing text into a
table:
»  Select the text to be converted into a table.
e Click the Insert tab.
*  Click the Table option.

e Click the Convert Text to Table from the
menu. The Convert Text to Table dialog
box appears on the scree.

* Select one of the options in the Separate
text at section and click the tabs option.

e Click the OK button.

The given text will be arranged in a table form.

P ctivity Time
Number of rows: 4
Number of columns: 5

Number of cells: 20

Brain Teasger
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More on MS PowerPoint 2016

Rapid Fire

1. To insert bulleted and numbered lists, we use
Home tab.

2. The Shapes command is located in Illustrations
group.

3. The Insert tab is used to insert SmartArt.

4. The Shapes command contains shapes such as
circle and rectangle.

Drag & Drop

Let's Review

. Tick (v) the correct option.

1. (a) 2. (b) 3. (¢)
4. (d)
. Write T for true and F for false statements.
1. T 2. F 3. T
4. F 5. T

. Answer the following questions.

1. In PowerPoint, a presentation is a group
of slides arranged in a systematic order
displaying information along with graphics,
movies, sound, etc.

2. The steps to insert a picture in a slide:

» Click the Insert tab in the Image group.
Insert Picture From dialog box opens.

*  Click the This Device option.
 Select the picture to be inserted.
+  Click the Insert button.

The selected picture will be inserted in the
slide.

3. A picture can be resized by dragging it from
its corners.

4. Thestepstoapply style to an inserted picture:
*  Click the picture.
»  Click the Format tab in the Pictures Tools.

» Click the More drop-down arrow to
display all the picture styles.

» Select the picture style required by you
and click on it.

The selected picture style will be applied to
the picture.

5. The steps to insert SmartArt:
»  Click the Insert tab.

* Click the SmartArt option from the
[lustrations group. The Choose SmartArt
Graphic dialog box apears.

e Select the SmartArt of your choice from
the left pane.

e (Click the OK button.

The selected SmartArt will be applied on the
slide.
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Ectivity Time

Tool

Use

This tool is used to insert a picture.

This tool is used to insert a shape.

This tool is used to add SmartArt in the
slide.

14—
I—
F—

This numbered list can be used to
arrange the text in numbers sequence.

*

Brain Teaser
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Model Test Paper — |

Tick () the correct option.

1. (c) 2. (a) 3. (b) 4. (b)

5. (a) 6. (d) 7. (c) 8. (b)

9. (a) 10. (c)

Fill in the blanks.

1. The joystick converts the movements of your
hands into electrical signals and inputs them
into the computer.

2. A microphone contains a device called an
amplifier inside it.

3. The main circuit board of a computer which
lies inside the CPU box is known as the
motherboard.

4. The Dot Matrix printers form characters and
image using patterns of dots.

5. The Windows Explorer window is used to
manage your libraries, folders, and files.

6. Back button helps to take you to previously
viewed folder.

7. The Content option displays files and folders
with its name, type and size information.

8. AutoFit button is located in Cell Size group
in the Layout tab.

9. DVD stands for Digital Video/ Versatile Disc.

10. The Windows Explorer window is used to

Keys "

manage your libraries, folders and files.

C. Answer the following questions.

1. A computer takes information or data from

an input device, store it to process, and after
completing the processing, it outputs the
result.

Input — processing — Output

. A CPU is a storage and processing unit. Its

two parts are given below.

Primary storage: Also called the main
memory, it keeps the information for a limited
time which gets removed after switching off
the computer.

Secondary storage: Also called external
memory, it does not lose the data even when
the computer is switched off.

. ROM, stands for Read Only Memory, is a

built-in memory which can only be read its
and contents is not lost after switching off the
computer.

. Output devices are computer hardware that

receive data from the computer and then
translate that data into usable form for the
use of the user. Monitor, and printer are
output devices.

. Main components of Window Explorer are:

Address bar, Refresh button, Search box,
Navigation pane, More options, Get help,
Menu Control bar, Details pane, Back button
and Forward button.

. The steps to create a folder on desktop:

» Click the mouse pointer at the blank area
of desktop. A drop-down menu appears.

* Click the New option. A drop-down
menu appears.

*  Click the Folder option.

A New Folder is created. You can change its

name.

. MSWord 2016 is the most popular and most

commonly used word processing software.
The main features of MS Word 2016:

e It types, edits, saves and prints text
documentslikeletters, stories, reports, etc.

It adds pictures in the document to make
it more attractive.

e It changes the look of the text using
different colours, styles and effects.

Drag & Drop



It gives a proper shape to documents by

adjusting page margins, shading, borders, | A

etc.

e It checks and corrects spelling mistakes
and grammar. B

e It allows the user create tables and insert
them into the text document.

8. Write the steps to add table in MS Word

document.

The steps to add table in MS Word document:

e Point the cursor where the table is to be
inserted.

e Click the Insert tab.

* Click the Table button in Tables group.

e Drag the mouse over the tables cells to
select the number of rows and columns in

the table.

¢ Left click the mouse on the right-bottom C.

corner of the cell.

The table will appear in the located place of

the document.

9. The Shape command in Illustrations group
contains shapes such as rectangle, triangle,
square, etc.

10. We can add SmartArt in a slide using these
steps:

* Click the Insert tab.

* Click the SmartArt option from the
Illustrations group. The Choose SmartArt
Graphic dialog box appears.

¢ Select the type of SmartArt from the left
pane.

e (Click the OK button.

More on MS Excel 2016

Rapid Fire
1. A cell is small rectangular area formed by the
intersection of row and column.

2. A file in MS Excel is known as a workbook.

3. Work area is a matrix of rows and columns that
forms cells.

4. Press the copy button or ctrl + C to copy contents
of cell.

5. Autofill feature helps you to automate data-entry
tasks.

Drag & Drop

Let's Review

. Tick (v) the correct option.

1. (¢) 2. (¢) 3. (a)
4. (a) 5. (¢)
. Fill in the blanks.

1. MS Excel is used to perform mathematical
calculations quickly.

2. The cell whose boundary is highlighted is
called an active cell.

3. File button is displayed at the top-left corner
of MS Excel window.

4. Formula box is used to enter and edit
formulae and perform calculations on your
worksheet data.

5. Cut and Paste commands are used to move

the contents of a cell to other cells.

Answer the following questions.

1.

A spreadsheet software is a special type of
software that results and analyses the entered
data arranged in rows and columns.

Spreadsheet software has many advantages.
Some of them are:

It allows users to perform calculations on
data quickly and accurately.

o It allows them sort data to view only
selected data items from a big collection
of data.

e It allows them format data to give a

desired look.

e It lets them convert a set of data into a
graph or a chart.

+ Itallows them edit and correct wrong data
entries easily.

It can store large spreadsheets effortlessly
on the computer.

MS Excel is an electronic spreadsheet
software. It is used to perform mathematical
calculations quickly. It provides built-in
features and tools that make it easier to work
with large amount of data.

A cell is the intersection point of the row and
columns which has no highlighted boundary;
whereas an active cell is where the cursor is
pointed and it has a highlighted boundary.

.7 Keys



5. Steps to copy and paste the contents of a cell: Advanced Features of MS Excel 2016
» Select the cell. Brain Teager
*  Click the Home tab. 1. Sort A to Z option in Sort & Filter button is
e Click the Copy button in the Clipboard selected to sort the data in alphabetical order.
group. 2. The ‘Order’ category in the sort dialog box is
e Select the cell where the contents to be used to arrange data either in alphabetical order
pasted. or ascending or descending order.
* Click the Paste button in the Clipboard | Rapid Fire
group. 1. In Excel worksheet, a complete row of
The cell contents will be pasted in the desired information is called a cell.
cell. 2. A column in worksheet containing data of a
6. Steps to insert cells below the selected cells particular kind is called a reference cell.
are: 3. The most common type of sorting is alphabetical
¢ Select the range of cells where cell to be ordering.
inserted. 4. The Sort & Filter button is in Editing group.
»  Click the Home tab. , ;
Click the L e Cell Let's Review
o 2 o meert a“t“e’:rlsn the Cells group- 1 A " Fill in the blanks.
i P Ppears. . 1. The Sort dialog box is used to sort on multiple
* Click the Insert Cells. The Insert dialog columns can make it easier to find the data
box appears. you need.
) S?IQCt the required option in the Insert 2. Filters can be applied in different ways to
dialog box. . h K ¢ Ksh
Click the OK button improve the performance of your worksheet.
. ic . . .
) ) ) 3. The Custom AutoFilter dialog box is used to
Thir e(;]ul'refl mllmber of cells will be inserted locate data based on specific conditions.
tt . . .
arthe .es.1re p ace 4. To redisplay all table data, click on the Clear
7. z?luto}ljl}l is an important fea(t:{ure of MS Exlc<el button from the Data tab.
that helps users automate data-entry tasks. .. . .
One can use AutoFill to add duplicate entries > ;fhle Conditional Formatting button is in the
or a data series to his/her worksheet cells. tyles group.
. B. Write T for true and F for false statements.
K ctivity Time 1T ) F 3T
I Button Group Tab N 4 T 5. F ) 6. T
con Name Name abiName || . Answer the following questions.
1. MS Excel is popular spreadsheet across the
o Insert Cells Home tab world because it is an electronic spreadsheet
software which is used to perform
Efk Delete Cells Home tab mathematical calculations quickly. It also
provides built-in features and tools that make
g it easier to work with a large amount of data.
|E Format Cells Home tab 2. In MS Excel, sorting is a way of arranging
data into meaningful order so that it can be
= Wrap text | Alignment | Home tab analysed more effectively.
3. In MS Excel, a field is an element in which
x| Merge & Alignment | Home tab a piece of information is stored, such as the
Centre received field. Generally, a column in a table

Keys "

contains the values of a single field.
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4. In MS Excel, data filtering is a way of
examining or displaying certain set of data
according to desired criteria.

5. Custom AutoFilter is a feature of MS
Excel which is used to find, show, or hide
values,based on specific conditions.

6. Conditional Formatting is a type of
formatting which allows users to change the
appearance of a cell, depending on certain
conditions.

7. Steps to sort in alphabetical order:

e Select a cell in the column from the
worksheet you want to sort.

e (Click the Home tab.

* Click the Sort & Filter button in the
Editing group. A list appears.

*  Click the Sort by A to Z option.
The selected column will be arranged in
alphabetical order.
8. Steps to sort multiple columns are:
+ Select the range of cells.
»  (Click the Home tab.

* Click the Sort & Filter button in the
Editing group. A list appears.

* Click the Custom Sort option. The Sort
dialog box appears.

*  Click the drop-down arrow in the Column
Sort by field and select on of the options.

* Click the drop-down arrow in the Sort On
category and select one of the options.

* Click the drop-down arrow in the Order
category and select one of the options.

e (Click the OK button.

The selected data will be sort out according to
commands.

Brain Teager

. |C|L|E[A[R]

2. [s|o|r|T|1|N]G]

s [e[rlefa[R][R[UTL]E s |
4 |cluls|[T]o|Mm|
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Button |Group| Tab
oo Name Name [Name Wz
It is used to change
Conditional the appearance of a
¥ Formatting Styles \Home cell based on
certain conditions.
Highlighted It is used when
= |Cell Rule Stvles [Home the conditions
=< "Greater 4 are greater than a
Than" certain value.
Highlighted It is used when
‘ Cell Rule Stvles [Home the conditions are
= "Less y less than a certain
Than" value.
T e
= |Cell Rule [Styles |Home
" " are between the
Between .
certain values.

QBasic — An Introduction
I ctivity Time

The labelled QBasic window is given below.
Program Title

Vertical Scroll Bar
[ #oaqeasicwqeasicxe [E=ES>

e Edit Uiew Search Run Debugl Optio He 1p

Menu Bar

<Shift*Fi=Help> <F6=Window> (F2=Subs> <{F5=Run> <F8=Step)>

Imr‘nediate
Mode Area

R 1
Horizontal

[
Status Bar
Scroll Bar

Prog‘ram
Area

I ctivity Time

The complete crossword is given alongside.
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Rapid Fire
1.

A program written in the machine languages is
called a machine code.

2. Microsoft Corporation developed QQBasic.

3. Compilers are also a software program like the

Keys "

assembler.

QBasic is considered to be a second-generation
language.

Let's Review

. Tick (V) the correct option.

1. (c) 2. (¢) 3. (¢)

4. (c) 5. (a)
. Write T for true and F for false statements.
1. T 2. F 3. T

4. F 5. T 6. F

. Answer the following questions.

1. A programming language is a computer that
users use to develop applications, scripts or
other instruction for a computer to execute.

2. A low-level language is a machine oriented
programming language that requires
extensive knowledge of computer hardware.
It provides a little or no abstraction of
programming concepts.

3. Language translators are software that allow
computer programmers to translate programs
in assemble language into the machine code.

4. QBasicisahigh-level programming language
developed by the Microsoft Corporation.

5. The basic elements of QBasic program are:
Character set, Variables, Constants, and
Operator.

6. The total number of consonants in a string
are said to be string consonants.

7. A variable in QBasic is a small quantity of
computer memory (or program) that has
been given a name. Its value can be changed
any number of times as required during the
execution of a program.

8. Some rules for naming variables are:
e Variable names can have maximum 40
characters.
e Variable names can have alphabet,
numbers and decimal point.

¢ A variable name must begin with a letter.

* A variable name cannot begin with fn or
FN letter. For example : fnames$, fnum,
etc.

* Variable names cannot be reserved words.

» Variable names may be concluded with
typed declaration characters like $, %, &,
I, and #.

9. Arithmetic operators are symbols that are
used to perform mathematical operations like
addition, subtraction, division, multiplication
and exponential. The arithmetic operators
used in QBasic for: addition — +, subtraction
— —, multiplication — *, division — / and for
exponential — .

10. Logical operators are symbols that combine
two or more relational expressions to evaluate
a single value as true (non zero) or false
(zero). The result of evaluation is used to
make decisions about the program flow. The

commonly used logical operators in QBasic

are AND, OR and NOT.

Arithmetic .
Explanation
operator

+ Add two or more numbers.

- Subtract tow or more numbers.
* Multiply two or more numbers.
/ Divide numbers.

A Calculate exponential value

I ctivity Time

The complete table is given alongside.

Brain Teager
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More on E-mail
P ctivity Time

The complete labelled mail window is given below.

To AddCc— AddBcc Subject Text Area
£l =
& ()= [M news//maiigoogiecommai fsnva-1ecompose ~ B [4]x ][ e varo B
x @~ = N
v B) v = d v Pagev Satetf~ Tooisv @~
gle
Gmail - SEND. Save Now| Discard Lajels &
Sleeis “ .
Inbox (119) L—e Add Cc AddBec
Starred S
:‘:’:n,::[: Attach a file Insert: Invitation
Drafts (10) B Z U T-T-A-T-@ec0i=i= EE 9 = CheckSppling~
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1. Cc stands for Carbon copy.
2. The details of the mails can be checked in Inbox
link.
3. Compose opens compose mail window where
you can write a mail.
4. Sent mail link stores the mails sent by you to

other e-mail accounts..

Let's Review

A. Write T for true and F for false statements.

1. F 2. F 3. F
4. T 5. T

B. Answer the following questions.

Drag & Drog

1. E-mail is one of the most used features of the
Internet, which helps communications to be
fast, reliable and accurate.

2. Some advantages of e-mail are given below:

e E-mails are easy to use.

e They are delivered at once around the
world

e They do not use paper.
e They can include pictures.

*  Products can be advertised with e-mails.

3. Steps to compose and send an e-mail:
e Open Internet Explorer and type WWW.
gmail.com in the address bar of Internet
Explorer.

* Type your login name and password in
appropriate boxes.

* Click the Sigh in. The account window
appears.

 Click the Compose button.
e Write e-mail address in the To box.

* Type the subject of the sending e-mail in
the Subject box.

* Click in Text area and write the message
for the receiver.

» Click the Send button. The e-mail will
immediately send to the recipient.
4. Steps to attach a file to an e-mail:
*  Open the Compose button.
»  Write e-mail address in the To box.

* Type the subject of the sending e-mail in
the Subject box.

* Click the Attach a file link. The select
file(s) to upload by mail google.com dialog
box opens.

e Select the file to be attached.

* Click the open button. The file gets
attached to the e-mail.

Click the Send button.
The e-mail will immediately send to the
recipient with the attached file.
5. Steps to delete an e-mail:
*  Click the Inbox.

e (Click the check box to select the mail to be
deleted.

*  Click the Delete button.
The e-mail will be immediately deleted.
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Scratch (A Programming Language)

Rapid Fire

1. A set of instructions given to a computer to
perform a particular task is called a program.

2. To start Scratch, first click the start button and
then Scratch program.

3. InScratch, a costume is one out of possibly many
frames or alternate appearances of a Sprite.

4. A Cap block is used to stop a script.

Let's Review
A. Tick (V) the correct option.
1. (b) 2. (d) 3.
4. (b) 5. (b)
B. Fill in the blanks with the correct words.

1. Programming is a technique for writing the
programs. The set of instructions given to a
computer to process the data or perform a
certain task is called a program.

2. A stack block has a notch at the top and a
bump at the bottom.

3. A hat block is a code block with a curved top
and a bump at the bottom.

(d)

4. Pen blocks are green colour-coded blocks.

5. Events blocks are used to control events and
triggering of scripts.

6. The Operators blocks are used to perform
Maths functions and string handling.

C. State whether True or False.
1. True 2. True
4. True 5. False

D. Answer the following questions.
1. Hat blocks used for starting a script.

3. False

2. The Reporter blocks are either rounded or
angled sides.

3. In Scratch, code blocks are grouped into
ten categories. They are: Motion blocks,
Looks blocks, Sound blocks, Pen blocks,
Data blocks, Events blocks, Control blocks,
Sensing blocks, Operators blocks and More
blocks.

4. Motion blocks are used for the movement
and rotation a Sprite.

5. Data blocks are used for storing information
used by applications when they execute.

6. The "set pen color to" blocks is used for
setting and changing the pen colour.

7. Scratch has three relation operators: greater
than, less than, equal to.

8. Scratch has three logic operators: And, Or,
No.

I ctivity Time

Used for

This block is used to add two values.

This block is used to checks if the first
value is less than the second value.

This block takes two expressions as
parameters.

This block takes only one expression
as input.

This block divides the second value
from the first value and gives the
result.

Artificial Intelligence (Machine
Learning)

Rapid Fire
1. Supervised machine learning is a type of machine

learning in which machines are trained using

labelled data.

. In supervised learning, machines are trained by
labelled data; whereas in unsupervised leaning,
the model learns from unclassified and unlabelled
data.

9/@®

DN

3. Deep learning is a type of machine learning
technique where algorithms are used to train
deep neural networks to achieve better accuracy.

4. Machine learning plays a very important role
in autonomous vehicles. It enables vehicles
to learn from data and predictions about their
surrounding world. For example, self-driving
car models are trained to detect people and
objects that come their way while moving.
The development of autonomous vehicles will
definitely revolutionaries the transport system.

Let's Review
A. Tick (V) the correct option.

1. (0) 2. (a) 3. (b)
4. () 5. (d) 6. (b)
Drag & Drop



B. Fill in the blanks.

1. Machines learn from the data they are fed and
automate learning.

2. In supervised learning, the labelled data has
the answers with it.

3. Cortanaand Siriare virtual personal assistants
which come in action with voice.

4. Insupervised machine leaning algorithm, the
model learns from labelled data.

5. In medial science, machine learning is used
for diseases diagnoses.

C. Write T for true and F for false statements.
1. T 2. F 3. F
4. T 5. T

D. Answer the following questions.

1. Machinelearning is an application of artificial
intelligence that enables machines to improve
at tasks with experience.

2. The full form of GNMT is Google Neural

Machine Translation.

3. Supervised learning algorithm is a type of
machine learning in which machines use
their past experiences labelled data. One
common example of supervised learning is
identification of things from their pictures,
say fruits.

4. Supervised learning applies past experiences
labelled for model to be trained, whereas
unsupervised learning uses neither classified
nor labelled data for model to be trained.

5. The two types of supervised learning are:
classification and regression: Classification
uses an algorithm to accurately assign test
data into specific categories.

6. Usefulness of machine learning in the given

fields:

(a) Bioinformatics: Machine learning
has played a very important role in
bioinformatics. Bioinformatics is the
analysis of biological data such as
fingerprints, iris texture, earlobe, and hair
colour of humans. The data is fed into the
model to train it. Machines use this data
to identify people. Aadhar cards are based
on bioinformatics.
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(b) Social media: In social media platforms
like Facebook, artificial intelligence 1is
used for face verification wherein machine
learning and deep learning concepts are
used to detect facial features and tag your
friends.

(c) Speech Recognition: Today, virtual
assistants have become a very common
technology. Almost every household
has a virtual assistant that controls the
appliances at home. The most well-
known wvirtual assistants include Siri,
Cortana and Google Assistant.

(d) Automatic Language Translation:
Sometimes we have visit a new place
where we are not aware of the language.
Today, it is not a problem at all because
machine learning helps us by converting
the text into our known languages.
Google's GNMT provides this feature
which translates the text into our
familiar language. It is called automatic
translation.

7. Reinforcement learning is an area of machine

learning in which models make a sequence of
decisions. It is about taking suitable action to
maximize reward in a particular situation. It
is employed machines to find the best possible
behaviour or path a model should take in a
specific situation. In reinforcement learning,
the given task is decided by a reinforcement
agent.

In the field of banking, machine learning is
playing a very important role. For payment
fraud, the model continuously supervises
customer behaviour and once a threshold
level of suspicion is detected, the bank is
notified and then has the information to
request additional authentication from the
customer.

In the field of medial science, machine
learning is used for diseases diagnoses. With
this, medical technology is growing very
fast and is able to build 3D models that can
predict the exact position of lesions in the
brain. It helps in finding brain tumours and
other brain-related diseases easily.
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The students will do it themselves.

Model Test Paper — Il
A. Tick (V) the correct option.

1. (b) 2. (a) 3. (b)
4. (o) 5. (b) 6. (b)
7. (c) 8. (b) 9. (c)
10.(b) 11.(a) 12.(c)
13.(b) 14.(d) 15.(b)

B. Write T for true and F for false statements.
1. T 2. T 3. F 4. F
5. T 6. F 7. F 8. T
9. T 10.F

C. Answer the following questions.

1. Some advantages of spreadsheet software are:
» Itis free and requires minimal training.

o It allows users perform calculations on

data quickly and accurately.

e Itiseasy to sort data to view only selected
data items from a huge collection of data.

o It allows users to format data to give a

desired look.

e It lets users to convert a set of data into a

graph or a chart.

» It allows users to edit and correct wrong

data entries easily.

e It can store large spreadsheets effortlessly

on the computer.

2. To copy cells contents and paste them to

other cells, we follow these steps:

e Select the cell contents and click the

Home tab.

e Click the Copy button in the Clipboard

group.

e Click where the cell contents to pasted.
e Click the Paste button in the Clipboard

group.

The selected cell contents will be pasted at

the desired place.

3. The main reason for necessity to have a
programming language for computers is to
communicate with the computers. Also the
programming languages are used to develop
an application for performing a specific task,

automating things, etc.
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. Custom AutoFilter is a feature in MS excel

that we use to find, show, or hide values in
one or more columns of data.

. To sort multiple columns, we follow these

steps:

 Select the range of cells.

» Click the Home tab.

» Click the Sort & Filter button in the
Editing group. A list appears.

* Click the Custom Sort option. The Sort
dialog box appears.

* Click the drop-down arrow in the Column
Sort by field and select on of the options.

» Click the drop-down arrow in the Sort On
category and select one of the options.

» Click the drop-down arrow in the Order
category and select one of the options.

* Click the OK button.

The selected data will be sort out according to
commands.

. Machine language is a collection of binary

digits or bits (0s and 1s) that the computer
reads and interprets.

. QBasicisahigh-level programming language

developed by the Microsoft Corporation. We
can easily convert the problem solving steps
shown in a flowchart or an algorithm into
the QBasic programming language to get the
problem solved by the computer.

. Arithmetic operators are symbols that are

used to perform mathematical operations like
addition, subtraction, division, multiplication
and exponential. The arithmetic operators
used in QBasic for: addition — +, subtraction
— —, multiplication — *, division — / and for
exponential — .

. Toadd an attachment to an e-mail, we follow

these steps:
*  Open the Compose button.
e Write e-mail address in the To box.

* Type the subject of the sending e-mail in
the Subject box.

* Click the Attach a file link. The select
file(s) to upload by mail google.com
dialog box opens.
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e Select the file to be attached.

* Click the open button. The file gets
attached to the e-mail.

e (Click the Send button.

The e-mail will immediately send to the
recipient with the attached file.

10. As the name suggests Control blocks let the
user control the blocks within the scrips,
inserting conditions statements, loops,
repeats and pauses. Five Control blocks are:
repeat block, forever block, if.. then block,
it ... then ... else block, stop all.

11. Five applications of machine learning are:
speech recognition, spam detection, social
media, bioinformatics and banking.

Cyber Olympiad
Choose the correct option.
L@ 2@ 3@ 4@
5.d 6 () 7.6 8 (b)
9. @  10.d)  11.(a)  12.(b)
13.(c)  14.(c)  15.(b)  16.(a)
17.(b)  18.(d)  19.(d)  20.(a)
2.b)  22.(c)  23.d)  24.(b)
25.(b)  26.(b)  27.(b)  28.(c)
29.(d)  30.(d)
i Class 72
More on Windows 10
Ectivity Time
1. S 2. S 3. E
4. S 5. E 6. E
7. E 8. S 9. S
10.S
Rapid Fire

1. Control Panel contains several links that is used
to change hardware or software settings.

2. Administrative Tools is example of software
settings.

3. Programs use the date and time to establish when
files and folders are created and modified.

4. You can add one or two additional clocks using
the Additional Clocks tab.
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Let's Review
A. Tick (V) the correct option.

1. (a) 2. (d) 3. (a)
4. (a) 5. (a)

B. Match the following.
1. (i1) 2. (iv) 3. (v)
4. (i) 5. (1)

C. Answer the following questions.

1. Control Panel is a feature of the Microsoft
Windows graphical user interface that
allows users modify computer's settings and
controls.

2. Follow these steps to change date and time of

a computer:

* Open the Control Panel and click the
Clock and Region link. Date and Time
dialog box appears.

* Click the Change time zone option. A
dialog box appears.

* Click the Change date and time button.
The Date and Time Settings dialog box
appears.

* Make the required changes in date and
time of your system and click the OK
button.

3. Follow these steps to set the double-click
speed of the mouse:

* Open the Control Panel and click the
Hardware and Sound link. A Hardware
and Sound dialog box appears.

* Click the Mouse option in Devices and
Printers section. A Music Properties
dialog box appears.

»  Click the Buttons tab.

e Drag the speed slider in the suitable
direction to set the double-click speed as
slow or fast.

 First click the Apply button and then OK
button.

4. An On-screen Keyboard is a feature provided
by Windows 10. It allows users to type text
using a joystick or a pointing device.

5. Disk cleanup is a utility of a Windows

operating system. It helps to clean up hard
disk.
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